Main Tutorial BMGT721

Building a Form

The following lessons will show you how to:

· Create a single-record block.

· Create a multi-record block, and a master-detail relationship between the two blocks.

· Modify the form's appearance by adding boilerplate text and graphics. 

· Modify the form's functionality by adding a button and a trigger.

We'll also provide a review of some Oracle Forms basics:  

· Development cycle 

· Triggers

· Built-ins

Oracle Forms Development Sequence














So, how do you get from beginning a form to a finished application, ready for operators to run?  

Here's the basic process:

	To do this:


Use this Developer tool:

	1.  Name the form.

Object Navigator

	2.  Connect to the database.
Developer menu command

	3.  Create blocks.


New Block window

	4.  Fine-tune the layout.

Layout Editor

	5.  Set properties.


Properties window

	6.  Add code


PL/SQL Editor

	7.  Test the form.


Runform


About the Data Block Wizard

In Lesson 1, you'll use the Data Block Wizard to quickly create a form. When you create a new Data Block, Oracle Forms uses information from the database to create a starting-point form.   This new form displays all the fields from the base table in a canvas without requiring any programming.   You can modify the canvas to suit the needs of your application as you progress.

The Data Block Wizard:

· Creates a base table block. 

· Creates an item for each column in the database table (You select the columns you want to use).

· Sets the properties for each item (such as name, datatype, and maximum length) the same way they're set in the database.

· Creates a default boilerplate text label for the block.

· Creates a boilerplate text label for each item; the default is the name of the corresponding column.

· Arranges the base table items on the canvas.

· Creates a single or multi-record block.

· Creates a scroll bar if specified.

· Creates and coordinates a master-detail relationship, if specified.

· Creates a basic form that will run with a default menu, providing basic database access operations.

Lesson 1: Create a New Form  

Now that you're familiar with the Developer tools, you've decided to try out the Data Block Wizard by creating an order entry form from scratch.   You'll call this new form Orders, and base it on the  tables S_ORD and S_ITEM. 

In this lesson, you'll create ORD_BLK; in Lesson 2, ITEM_BLK.   

	Data Block Name
	Base table/control
	Records Displayed
	Master/Detail

	ORD_BLK
	Base Table: S_ORD
	Single Record
	Master to ITEM_BLOCK

	ITEM_BLK
	Base Table: S_ITEM
	Multi-record
	Detail to ORD_BLK


Name the Form Module

Before you can use the Data Block Wizard to create a default form, you need a new form module.  In the Oracle Forms object hierarchy, forms own blocks, so you must create the form first, and then the block.

1. Double-click on the Developer icon to open the Developer.  Oracle Forms opens the Navigator with a default form called MODULE1, with the name selected.  

2. Click once on the default name, MODULE1. This click causes Oracle Forms to enter edit mode, and the cursor changes to an I-beam text cursor.

3. Double-click the default name to select it, then type: ORDERS  If you leave this node and need to try this step again, click once to select the form name, and once again to set the I-beam cursor.  Then double-click and type.

4.
Press Enter to accept the name change.  The status line displays Mod: ORDERS, File: ORDERS.

Developer's Note:  

Guidelines for naming a form module:

· Names must begin with an alphabetic character.

· Names can be up to 30 characters.

· Can include letters, digits, and underscores. For example: SALES_30 is OK; 30_SALES is not OK.

These guidelines apply to all Oracle Forms objects, and correspond to the Oracle8 Server naming conventions.  In addition, if you are saving a form module to an MS Windows file, limit the name to 8 characters or fewer.

Connect to the Database  

Because the blocks you create are based on database tables, you need to connect to the database before using the Data Block Wizard.  If you proceed with this step without connecting to the database server, the wizard will ask you to connect before letting you continue.

1.
Select File->Connect.  Oracle Forms displays the Connect dialog.

2. Fill in the username, password, and connect string.  Consult your DBA if you have problems.

3. Click Connect.  When you connect to the database successfully, the status line displays the Connect lamp: <Con>.

If you receive any error messages indicating that the database connection has not been made, consult your DBA for assistance. 

Note:  Once you have connected to the database, you  can browse through the Database Objects  and examine all the tables that have already been created  in your account to use with this tutorial and with the sample.fmb application that was demonstrated in class.

Note:  You will not be able to use the New Block window to create a form unless you have a successful database connection to give you access to the SUMMIT2 tables (same as for sample.fmb).

Create a Base Table Block  

Using the Data Block Wizard to create base table blocks is the quickest way to start building a form.  First, you'll create the single-record block, ORD_BLK.  Base table blocks are based on the columns of a particular database table: in this case, the S_ORD table.

1.
Select Tools->Data Block Wizard.

The Developer displays the Data Block Wizard.  Choose next to start.  Select type of data block by clicking “Table or View” before proceeding.  In the next window you can browse the tables in your account – click “current user” and “tables”, and select S_ORD from the list that comes up after you push OK.  Contact GA or administrator if the tables are not visible when you browse your account.  The Data Block Wizard now lists all the fields in the particular table you have chosen – in this case S_ORD.  Click each of the fields to move them over from “available columns” to “database items”.  When you click next you will have an option to create a form.   Although you may not always need to use this option, this time you should choose it in order to create a basic form based on your first Data Block.  When you click finish you will be taken to the Layout Wizard.  

Layout Wizard

When the Layout Wizard has opened, click next to proceed.  You will once again be asked to choose the fields to include – but this time you are selecting the fields that should be displayed on your form.  Click all the fields to include them in the form and go next.  Accept the default characteristics on the fields (you can change these later if needed), and click on “form” in the next window.  When you click next you will be asked to name the frame and choose number of records to display.   Name the frame something that makes sense – this is only for the canvas and you can change this later.  Click finish to complete the form.  You should now have a data block and a canvas in the object navigator.  

Go to the data block and rename it ORD_BLK from the default, which usually is the name of the table: S_ORD.  This is done the same way you changed the name on Module1.  Under “items” you can check that all the fields were included in the data block.  Also, check that the canvas is named ORD_CAN, change it if needed. 

Note: When a new form is created, by default all database items are displayed as plain text items.  When an operator runs a form, the value of text items can be changed.  You don't want the operator to change the value of the ORDER_FILLED item (it's changed only by the Order department).  Instead, you want to make the ORDER_FILLED item read-only.  Display items are read-only, so you make ORDER_FILLED a display item.  Select ORDER_FILLED and go to Tools>Property Palette and change the item type to display item.

When you finished the data block wizard, Oracle Forms creates a new block based on the S_ORD table, with these characteristics:

· All fields displayed in sequence across the width of the form (Form Style).

· Text fields displayed with space between them (Spacing=10).

· One record displayed at a time.

Examine the Item Properties (property palette or F4).

When you created the ORD_BLK data block, Oracle Forms inserted the block and its items in the object hierarchy displayed in the Navigator.  When you select an object in the Navigator, its properties are displayed in the Properties window.  When you created ORD_BLK, you specified that all of the items should be text items, except ORDER_FILLED, which should be a display item.  In the following steps, you'll use the Developer tools to verify that the items in ORD_BLK were created as you specified.  

1. In the Navigator, under Data Blocks--ORD_BLK, click on the Items node to expand it. Notice that the Text Item icon precedes all the items except for ORDER_FILLED, which shows the Display Item icon.

2. Under Data Blocks--ORD_BLK--Items, click on PAYMENT_TYPE. To verify the item type of the items, check the property setting in the Properties window.

3. Double-click the Text item icon preceding PAYMENT_TYPE to raise the Properties window. Or, choose Tools->Properties.

4.
In the Properties window, verify that the Item Type property for Payment Type is Text Item. 

5.
In the Navigator, under Blocks--ORD_BLK-- Items, click on ORDER_FILLED. 

6.
In the Properties window, verify that the Item Type property for Order Filled is Display Item. 

Examine the Layout

Next, inspect the new block in the Layout Editor to check on the appearance you specified.  

1) Select Tools->Layout Editor. Oracle Forms opens the Layout Editor, displaying ORD_CAN.  The ruler settings increment rapidly (0-14-28...) because the default is set to Points.  You decide to change the ruler setting to Centimeters.

2) Choose Format->Layout Options->Ruler. Oracle Forms displays the Ruler Settings window.

3) In the Ruler Settings window, set the following options: 

a) Units:

Centimeters

b) Grid Spacing:
.25
c) Snap Points
1
4) Click OK to accept the new settings.

5) Inspect the new block layout. The New Block window created a text item for each column in the S_ORD table (except ORDER_FILLED) with a boilerplate label derived from the column name. If your layout shows all the items horizontally in a single row, creating a long and narrow form, you may have specified Style as Tabular instead of Form.   Follow the recovery steps listed in the Developer's Note below.    

6) Close the Layout Editor. 

Developer's Note:  

The Data Block Wizard was designed for one-time use, to provide starting-point forms.  If you make a mistake, or change your mind once you see the form, use the following strategy to recover:

· In the Navigator, delete ORD_BLK.

· Open the Data Block Wizard and re-create the block.

Save and Run the Form

Now that you've completed the first block, it's time to save and run the form.  When you run, you can test this block's functionality, then return to the Developer to make changes or create additional blocks. 

1. Select File->Save to save the ORDERS form to a file. The status line currently shows Mod: ORDERS File: ORDERS. Oracle Forms displays the Save As dialog, showing a default name of orders.fmb. The file will be saved in the directory displayed, so check the directory, and change if necessary.

2. Click OK to accept the default name and save the form. Oracle Forms displays the message: Module saved successfully.

3. Select Program->Run Form.  Oracle Forms displays the message: Module generated successfully. Oracle Forms displays the form in a Runtime window.  Note that if you are not connected when running the form you will be prompted to do so.

Developer's Note:  

Why have both Module Name and File Name?  In the Save As dialog, Oracle Forms displays the module name (the name you gave the form in the Navigator) as the default file name.  You can keep these names the same, or create a different file name in order to comply with file naming requirements.  For example, the module could be stored in the database under a name such as custapp003, which would exceed the  MS Windows 8-character file name limit.

Test the Form

You can quickly test the form by executing an unqualified query to call up all the records in the test database. 

1. Select Query->Execute. Oracle Forms displays Order 100 for Customer 204, Womansport.  (The customer name, "Womansport," is not displayed, because it is not part of the S_ORD table on which this block was based.) 

2. Use the blue arrow keys in the tool bar to move through as many of the database records as you want to see.

3.
Select Action->Exit to leave the form. Oracle Forms returns you to the Developer.

Developer's Note:

When you run this new form, it displays the default menu familiar to you from the Sample form.  Most forms run with a menu: either the default menu provided with no extra coding, or a custom menu.  (You can choose to run without a menu.)  If your application requires a custom menu, you can use the graphical Menu Editor to quickly create a unique menu. 

Lesson 2.  Add a Multi-Record Block   

Now it's time to add the S_ITEM data block to the Orders form.  The S_ITEM contains information about items related to a specific order, so you'll create it as a detail block connected to the master block, ORD_BLK.

Create the Detail Block  

Choose Tools->Data Block Wizard.  

The Developer displays the Data Block Wizard.  The process is the same as when you created ORD_BLK, but this time select S_ITEM from the list.   You will now have the option to create a master-detail relationship, which is a join-condition between two data blocks.  In this case you want to create a join between ORD_BLK and S_ITEM.  For some reason the wizard will not let us change the name of the data block while doing this, so we will accept the default data block name of S_ITEM from the base table.  Make sure “Auto-join Data Blocks” is checked, and click on the button that says “Create Relationship”.  The wizard will show a list of possible master-blocks - in this case ORD_BLK is the only one available.  Highlight ORD_BLK in the list and click OK.  ORD_BLK will now show in the window that says “Master Data Blocks”, and you can manipulate the detail and master items to determine the join-condition, which should read S_ITEM.ORD_ID = ORD_BLK.ID. 

Click Finish and continue to the Layout Wizard.  Select ORD_CAN from the drop-down list and click next.  Continue in the same fashion as when you created ORD_CAN, but select Tabular instead of Form and write 4 instead of 1 in “records displayed” before finishing.  Also note that you need to check “show scrollbar” for the S_ITEM display.

Oracle Forms creates a new block based on the S_ITEM table, with these characteristics:

· All fields displayed in columns (Tabular Style).

· Multiple records displayed vertically (that is, each one below the preceding record, rather than beside it) with text labels displayed above each item (Vertical Orientation).

· Text fields displayed adjoining, with no space between them (Spacing=0).

· Four detail records displayed at a time.

· Linked to the ORD_BLK based on the join condition.

· Note that if you attempt to change the name of the data block, the join condition may be lost.

Examine the Layout

Inspect the new block layout in the Layout Editor to check on the appearance of the ORDERS form, now that it includes both ORD_BLK and S_ITEM. 

1.
Choose Tools->Layout Editor.

3. Inspect the new block layout.  Four rows of items are displayed for each order, with a scroll bar to display additional items.  

4. Close the Layout Editor.

Save and Run the Form

You've completed the second block of the form, so it's time to save and run again.  Now you can test both blocks, including their master-detail relationship. 

1.
Select File->Save to save the Orders form.


Oracle Forms automatically saves the file under the same name you specified during the last save. 


The status line shows:  Mod: ORDERS File: orders.fmb

2.
Choose Program->Run Form to run the Orders form, or click on the Run Form button on the left side tool bar (top tool bar if you are in the layout editor).

Test the Form

With this test, you can check for the coordination of the master-detail blocks, verify that the correct number of detail records is returned, and confirm the presence of the scroll bar and button palette as specified.

1.
Select Query->Execute to execute an unqualified query.


Oracle Forms displays Order 100 for Customer 204, Womansport.

2.
Press the blue arrow keys to display the next order.

As you move through the orders, notice how the master-detail relationship displays the products associated with each order.  This coordination is the result of the join condition you entered using the New Block window, and requires no further programming.     

3.
Continue to press the down arrow until you reach Order 105.

Notice that the scroll bar in the Items block is disabled.  Order 105 has fewer than four items, so the scroll bar isn't needed. 

4.
Press the Down arrow key to display Order 106.

Order 106 includes six items, so now the scrollbar is enabled.  Use the scrollbar to display items 5 and 6.  You've confirmed that all six detail records were retrieved.

5.
Select Action->Exit to leave the form.

Oracle Forms closes Runform and returns you to the Developer. 

Lesson 3:  Modify the Form  

At this point, you're satisfied with the basic layout of the form, but want to make some adjustments to improve its appearance and functionality.  The following things can be done easily in the Layout Editor:

· Add a title.

· Add a line under the title.

· Format boilerplate text.

· Add a button.

To begin, choose Tools->Layout Editor.  Most of the layout tools are in Format in the top tool bar.  Rather than going in detail into how you change the format of your forms, you can explore the tools that are available.

Developer's Note:

If you want to experiment on your own with creating a more sophisticated appearance for your form, here are some starting points:

1) In the Navigator, create a new form called TEST.

2) Open the Data Block Wizard and create a new data block based on S_ORD base table.   Rename the data block TEST_BLK.  

3) Skip the Master/Detail setup, and click OK.

4) Go to the Layout Wizard and create a canvas based on TEST_BLK, and name it TEST_CAN.

5) In the Navigator, select TEST_CAN.

6) In the Properties window, set the TEST_CAN property, Background Color, to Gray20.

7) Open the Layout Editor.

8) Delete the default block title and outline.

9) Using the boilerplate rectangle tool, create a frame around the items.

10) Set Line Color to Black. 

11) Set Fill Color to No Fill.  No Fill is transparent--the canvas-view color will now show through. 

12) Select the frame and choose Format->Line->2 pts.

13) Choose Format->Bevel->Inset.

Inset gives the line a sculpted appearance. You can also try out the other Bevel options.  This command sets the bevel for boilerplate; to set a bevel on Oracle Forms objects, use the Bevel property.  

Add a Button 

Now you want to add a Help button to display the Show Keys window.  You want the Help button to belong to a separate data block that you can name BUTTON_PALETTE block.  Since this data block is not based on a table in SQL, you cannot use the Data Block Wizard.  Instead, copy any of the other blocks and paste it in.  Then rename it BUTTON_PALETTE and go into properties and change the characteristic called “Data Base Data Block” to NO.

Note that in the Layout Editor the title bar shows the block name in parentheses: ORDERS: ORD_CAN (ORD_BLK).  This indicates that ORD_BLK is the current block context for the Layout Editor: any items you create now will belong to ORD_BLK.   So your first step will be to set a new block context.

1.
Click on the Block poplist.


Oracle Forms displays a list of blocks for the form.  

2.
Click on BUTTON_PALETTE to set the block context.  

Now the title bar shows the new block you just selected: ORDERS: ORD_CAN (BUTTON_PALETTE).  


The block context for the Layout Editor sets the block parentage for any items you now create.  If you had made the button before setting the block context, the button would have been assigned to ORD_BLK, no matter where you placed it on the canvas.  Because you set the block context to BUTTON_PALETTE, the button you create will belong to the appropriate block.

Developer's Note:

Block parentage for items is important because the items acquire certain characteristics from the parent block.  For example, if you had not specifically set the block parentage to BUTTON_PALETTE, the button would, by default, have been part of the current block, whether that was ORD_BLK or ITEM_BLK.  If, for instance, the current block had been the ITEM_BLK, when you made a button, Oracle Forms would have automatically created four buttons, because ITEM_BLK is a multi-record block set to four records.

 You can always tell the current block from the Layout Editor title bar.  Any items you create will be assigned to that block.  Block parentage can be changed in the Layout Editor by selecting the item and changing the block in the poplist.

Blocks are logical containers only.  The items in a block can be placed anywhere on a canvas, or even on separate canvases displayed in different windows.

1. In the Layout Editor, use the scroll bars to adjust the display so you can see the lower right corner of the form, at the right of the button palette.

2. In the tool palette, click on the Button tool.   
The Button tool is right below the Text tool (T).  

3. In the Layout Editor, click at the right side of the button palette to create a default button.

The button is created with a default label, such as PUSH_BUTTON4.  The button now has handles around it, so you can click and drag if you want to resize or reposition it.  (If the button is very large, check to be sure View->Snap to Grid is Off.) 

Now you want to set the properties of the button you just created. 

4. Double-click the button to raise the Properties window.  The Properties window displays the properties for PUSH_BUTTON4.

5. In the Properties window, click on Name.  The Properties window displays the current value of the Name property in the change box.  Whatever you type next will appear in this box.

6. Type the new name: HELP_BUTTON

7. Press Enter to accept the change.

Although the name has been changed in the Properties window, in the Layout Editor,  the button is still labeled PUSH_BUTTON4.  Changing the label is the next step.

If Oracle Forms returns the message, FRM-15500: Valid and unique name must be entered, check to be sure you included the underscore in HELP_BUTTON.  Two-word names include an embedded space, which is not valid in PL/SQL.  The Label property allows you to create a button label free of these restrictions.

Now you're ready to change the Label property.  Each button has both a name, used to refer to the button in trigger code, and a label, which appears in the user interface.  The name must adhere to PL/SQL naming standards, while the label can be more flexible for usability purposes.

8. In the Properties window, scroll down until the "Functional" properties category is visible.

9. Click on Label.
The default Label text appears selected in the change box at the top of the Properties window.

10. Type the new label you want to appear on the button: Help.  Many Oracle Forms developers follow the standard practice of limiting button labels to a single word, starting with an initial capital letter.

11. Press Enter to accept the new value.

12. In the Layout Editor, verify that the button is now displayed with the new label, "Help." 

13. Close the Layout Editor.

About Triggers






A trigger is a block of PL/SQL code you write to customize your application.  Although you could create a basic application without writing triggers, using only Oracle Forms' default processing to retrieve, add, delete, and change database records, you will usually need to write triggers to customize your application.  A trigger’s PL/SQL code contains orders to perform certain functions that are triggered by the event it is attached to, such as a button or form event.

You use triggers to respond to runtime events with appropriate processing.  For example:

· The operator presses a button.  You could create a When-Button-Pressed trigger to display details about a customer's credit rating.

· The operator enters an order total that exceeds the customer's credit limit.  You could create a When-Validate-Item trigger to check the order total against the credit limit and reject the order.  

Attaching Triggers to Objects

Triggers encapsulate PL/SQL code so that code can be associated with an event and executed and maintained as a distinct object.  Oracle Forms recognizes a predefined set of runtime events, each of which has a corresponding trigger, such as the When-Button-Pressed trigger.  When you add code to an application by writing a trigger, you must decide which event should execute the code ("fire" the trigger). 

A trigger must be attached to a specific object in the form, such as a button.  For example, a form might have three buttons, and thus three When-Button-Pressed triggers.  When the operator presses Button 1, only the When-Button-Pressed trigger for Button 1 is fired, because when you defined the trigger, you attached it to Button 1.  You also defined When-Button-Pressed triggers for Buttons 2 and 3, but because only Button 1 was pressed, only that button's trigger was fired.

Triggers are not limited to items.  Triggers can be attached to any object in the form: an item, a block, or the form itself.   

	Attaching a trigger at this level…
	Produces this result

	Item Level: Button 1
	Fires Only when button 1 is pressed

	Data Block Level
	Fires when any button in the block is pressed

	Form Level
	fires when any button on the Form is pressed


Add a Trigger 

Now you've created a button on the canvas, but for the button to work, you need to attach a When-Button-Pressed trigger.  The trigger will contain the code you want executed when the button is pressed.  To create a trigger, you'll use a new Developer tool, the PL/SQL editor. 

1. Return to the Navigator, where the HELP_BUTTON should still be selected.

1. Click on the + in front of the HELP_BUTTON to expand the node. Oracle Forms expands the HELP_BUTTON node, showing an empty Triggers node below it.

2. Double-click on this Triggers node to create a new trigger. Oracle Forms displays the Triggers dialog, with the cursor already in the Find box.

3. Find the WHEN_BUTTON_PRESSED trigger by scrolling down the list that comes up.

4. Click OK.

Oracle Forms raises the PL/SQL Editor, displaying a blank When-Button-Pressed trigger.

You want this Help button to display a list of key combinations, such as Ctrl-C.  To accomplish this requires no PL/SQL code: you simply create a trigger consisting of the Show_Keys built-in subprogram.  (Built-in subprograms are pre-compiled routines that perform many frequently-used tasks.) 

5. Click in the PL/SQL Editor, and type: Show_Keys

6. Click the Compile button. 
Because the semi-colon is missing, the PL/SQL editor displays an error message.

7. Click after Show_Keys, add the semi-colon, and Compile again.  The PL/SQL editor displays a Successfully Compiled message.

If the PL/SQL editor still reports errors, check to be sure Show_Keys contains an underscore (_), rather than a hyphen (-).

8. Close the PL/SQL editor.

Developer's Note: 

In the Navigator, Oracle Forms displays the WHEN_BUTTON_PRESSED trigger you just created.  You know the trigger is attached to the button because it appears in the Triggers node below the Help_Button.  To verify this parentage, click in the Context poplist at the top of the Navigator.

The Context poplist shows the parentage for the current object: ORDER_BUTTON_PALETTE--HELP_BUTTON--WHEN-BUTTON- PRESSED.  You can also use the Context poplist to navigate, by clicking on an object in the list.

Save and Test the Form

1.
Select File->Save to save the ORDERS form. Or, click on the Save icon.

2.
Select File->Run to run the ORDERS form. 
Or, click on the Run icon.

Oracle Forms opens Runform and displays the ORDERS form. With this test, you can check for successful execution of the When-Button-Pressed trigger and review the boilerplate changes you made.

3.
Select Query->Execute to execute an unqualified query. Oracle Forms displays the first record.

4.
Click on the Help button.
Oracle Forms displays the Keys window.

5.
Click OK to dismiss the Keys window.

6.
Choose Action->Exit to leave the form and return to the Developer.

7.
Choose File->Exit to leave Oracle Forms.

Congratulations!   You have completed the core Oracle Forms Developer tutorial. You've used the main Developer tools:

· Object Navigator

· Properties window

· Layout Editor

· PL/SQL Editor

In a subsequent lab you will add more functionality.

· A list of values or  LOVs, that allows you to choose from a list of values to input data in your application.  

· Construct PL/SQL code that can provide LOVs to your specifications.  

· System generated sequences to maintain the values in some key fields of your tables.  

· Built-in subprograms.

· Customized subprograms using PL/SQL.

Contact DBA or GA if you have problems with the preceding exercises.

Here is more reference material on triggers and subprograms for later reference.

Using Triggers in Forms

Through triggers, you can control the following types of tasks:

· Validate data entry.

· Protect the database from operator errors.

· Limit operator access to specified forms.

· Display related field data by performing table look-ups.

· Compare values between fields in the form.

· Calculate field values and display the results of those calculations.

· Perform complex transactions, such as verifying totals.

· Display customized error and information messages to the operator.

· Alter default navigation.

· Display alert boxes.

· Create, initialize, and increment timers.

Strategies for Developing a Trigger

Consider the following points before writing a trigger:

· What event will cause the trigger to fire?  (Determines the name or type of the trigger.)

· What is the trigger scope: form, block, or item?  (Determines the level at which the trigger is defined.)

· What actions will the trigger perform?  (Determines the commands, logic, and built-ins required.)

· What possible exceptions may arise? 

· Under what circumstances should the trigger fail?

Getting Started with Triggers

Oracle Forms supplies 80 different triggers, which provides flexibility for customizing your forms, but can seem a bit daunting at first.

You may be wondering where to start in learning about triggers.  In this chapter, you created a When-Button-Pressed trigger, which is a good starting point, because every button on a form will need a When-Button-Pressed trigger.  Next, you may want to experiment with these other commonly used triggers:

· When-Validate-Item

· When-New-Form-Instance

· When-Create-Record

· Pre-Query 

· Post-Query

For information about working with triggers, see the Oracle Forms Developer's Guide, Chapter 7, "Writing Event Triggers."  For details about each trigger, use the online Help system.  The demonstration form sample.fmb has many useful examples of triggers.

Groups of Triggers

If you look at the list of triggers in the Table of Contents of the Oracle Forms Reference Manual, Volume 1, you'll see that triggers fall into groups that start with the same word and provide similar functions. 

	Group
	Function
	Importance

	When-triggers
	Augment Default processing
	High

	On-Triggers
	Replace default processing
	Used primarily with Non-Oracle Data sources

	Pre- and post-triggers
	Add processing before and after an event
	Better to use navigational triggers

	Key-triggers
	change default processing assigned to a specific key
	Less useful in GUI environments


Trigger Functions

Within these broad groups, triggers can be divided by their functions.  

	Function
	Purpose
	Example

	Block Processing
	Fires in response to record management in a block
	WHEN_CREATE_RECORD

WHEN_CLEAR_BLOCK

	GUI Events
	Fires in response to event happening in form interface
	WHEN_BUTTON_PRESSED

WHEN_TIMER_EXPIRED

	Master-detail
	Fires during master-detail processing
	ON_CHECK_DELETE_MASTER

	Message Handling
	Fires when an error occurs or a message is needed
	ON_ERROR

ON_MESSAGE

	Navigational
	Fires as Oracle forms navigates internally through the object-hierarchy, fires at the end of navigational sequence
	PRE_BLOCK, PRE_FORM

POST_BLOCK, POST_FORM

WHEN_NEW_BLOCK_INSTANCE

	Query time
	Fires just before and after an operator executes a query
	PRE_QUERY

POST_QUERY


About Built-in Subprograms

Your trigger code can include calls to Oracle Forms built-in subprograms (called built-ins) as well as custom PL/SQL code.   A built-in subprogram is a predefined procedure or function supplied by Oracle Forms to handle many predictable application functions: 

	Type of function
	Example of built-in

	Move the input focus
	PREVIOUS_ITEM, GO_BLOCK

	Perform data operations
	EXECUTE_QUERY, COMMIT

	Control display of objects
	SHOW_LOV, SHOW_WINDOW, SHOW_ALERT

	Set a property for an object
	SET_ITEM_PROPERTY, SET_BLOCK_PROPERTY

	Display a message
	MESSAGE

	Invoke another form
	OPEN_FORM

	Determine the outcome of the action most recently performed by a built-in
	FORM_SUCCESS


Oracle Forms provides over 200 built-ins to make writing triggers faster and save you time in debugging, because the built-ins are all pre-tested and free of bugs.  
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